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Dreamweaver Frames 
 
Frames provide a way to divide a browser window into multiple regions, each of which 
can display a different HTML document.  In the most common use of frames, one frame 
displays a document containing navigation controls, while another frame displays a 
document with content and perhaps a third frame may contain the logo and title of the 
website.   These frames together are called a frameset.   
 
A site that appears in a browser as a single page comprised of three frames actually 
consists of at least four separate HTML documents.  When you design a page using 
framesets, you must save the frameset file and the three documents containing the content 
that initially appears inside the frames.   
 
Frequently, the document displayed in the top frame never changes as the visitor 
navigates the site.  The side frame serves as a navigation bar containing links to other 
pages that are displayed in the main content frame.     
 
The example you will be using for this exercise is a collection of pages describing the 
Rock Garden in front of the Math and Computer building. 

Designing the Layout of the Screen 
 
To use frames with a page, you first have to decide how you want to divide up the screen 
into frames.  For example, if you just wanted a header that stays at the top of the page, 
you would divide the screen into two frames.  However, for our exercise we will need to 
have a header at the top, a list of rocks down the left hand side and the information for 
each rock displayed in the bottom right frame. 

Setting Up the Frames 
 
1. Start up Macromedia Dreamweaver.  From the File pull-down menu, select 

New to ensure that you are starting with a new document.   
 
2. A New Document dialogue box will appear.  Select Framesets from the 

Category options and Fixed Top, Nested Left from the Frameset selections.  
Click on Create. 
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Alternatively, from a basic html document you can choose to use framesets by selecting 
Frames from the Insert Bar and then selecting the desired frameset.   If you do not see 
the Insert Bar along the top of the document window, select Insert from the Window 
drop-down menu. 

↓ 

 
 
3. You can resize the areas (frames) on your document by moving your mouse over 

the frame lines and dragging (the cursor will change to a double headed arrow).   
Clicking on the frame lines will also access the Properties Inspector where you 
can specify an exact pixel width. 

Frame Properties 
 
Frames, like any other object, have a number of properties that you can set, such as the 
source for what goes into the frame.  However, unlike most objects, selecting the frame is 
not as simple as clicking on it.  The easiest way to select and modify the frame is via the 
Frames Panel. 

Frame Names 
 
1. From the Windows drop-down menu, select Others and then Frames. 
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2. A Frames Panel should appear with a topFrame, mainFrame and leftFrame. 
Clicking on each of these areas will access the Properties Inspector.   

 

 
 
3. We should change the Frame Name to mean something more meaningful.  Start 

by clicking on the mainFrame box.  Change the Frame Name to 
RockInfoFrame.  Notice that the mainFrame is now called RockInfoFrame. 

 

 
 

4. Rename the leftFrame to RockListFrame and the topFrame to HeaderFrame. 
 
5. We need to save this frameset.  Make sure that you have selected the frameset by 

clicking on <frameset> from the bottom bar of the document window.  
 

 
 

6. From the File pull-down menu, select Save Frameset.  Call this file Frame-
Page.html. 
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Attaching a Web Page to a Frame 
 
You can associate a source page with a frame so that when the page first loads, this file 
will appear. 
 
1. Select the RockInfoFrame by clicking this frame in the Frames Panel.  Change 

the source (Src) to be garden-sign.html as shown below: 
 

 
 

2. You should see the garden sign picture in the bottom right hand frame.   Whether 
you have scroll bars will be determined by the size of the document window. 

 
3. A title web page has not been created for you.  So we will have to create a brand 

new file and include the information that we wish to have appear in the Header 
Frame. 

 
4. From the File drop-down menu, select New.  Choose Basic Page and click on 

Create.  Type Geological Garden.  You may wish to center this text, increase the 
font size and perhaps change the font colour.  Save this file as Title.html.   Return 
to your frameset.  This can be done by either closing the Title.html document or 
clicking on the Frame-Page.html tab at the bottom of the window. 

 
5. Select the HeaderFrame from the Frames Panel and change the source to the 

file that we created in the previous step (Title.html). 

Web Pages Created Directly in a Frame 
 
1. It is possible to create a page directly in a frame.  Click in the RockListFrame 

and type the following information: 
 

Rocks Found In the Garden 
 

• Anthracite Coal 
• Granite Gneiss Boulder 
• Keweenawan Conglomerate 
• Neptheline Syenite 
• Porphyritic Biotite Granite 
• Tyndall Stone 
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While you are still within this frame, choose Save Frame from the File pull-down menu 
and save the contents of this frame as rockindex.html.  Your page should now resemble 
the one below: 
 

 

Modifying the Frame Borders 
 
Depending on the overall look you wish to achieve, your borders may be transparent (so 
that it looks like one page with a navigation bar at the left hand side) or visible (so that it 
is readily apparent that the web page is using frames).   
 
1. If your frame borders are not available, select Visual Aids from the View pull-

down menu and select Frame Borders. 
 
2. Shrink the header Frame to as small as possible, by placing the cursor over the 

frame border.  It will change to a double headed arrow.  Then click and drag it to 
remove any excess space in the header area. You may need to adjust the left hand 
frame to completely display the rock names. 

 
Note:  Do not set the border tight with the text.  The browser displays the text slightly 
larger than it will appear in your source document. 
 
3. Select the header frame and look at the Properties Inspector.  Notice that the size  
 (in this case height) is 72 pixels.  If you wanted to have a precise value, you can 

set it here.  Under the Units, you can choose pixels, percentage or relative options.  
Pixels are the most common choice. 
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In addition, you can specify whether you want the frame borders to be shown and alter 
their size and colour.  If you wish, you can try out some of these settings, but remember 
to preview your pages in the browser to see exactly how they look or respond to these 
settings. 

Changing the Background Colour of a Document in a Frame 
 
You can change the background colour in a frame so that it stands out from the other 
frames.  Unlike many of other properties that pertain to a frame, the background colour is 
linked to the document within the frame. 
 
1. Click somewhere within the frame that will have its background colour changed.   
 
2. From the Modify drop-down menu, select Page Properties. 
 
3. Click the Background pop-up menu to select the desired colour.   
 
4. Click on OK to apply this colour selection. 
 

 

Links 
 
For the purposes of our frameset, we will want to link the names of the rocks in the left 
hand frame to html documents that we will want displayed in the main frame.   This will 
allow the left hand frame to be used as a navigation tool. 
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1. Select the text Anthracite Coal as shown below: 
 

 
 

2. In the properties dialog window, set the Link property to anthracite.html. 
 

 
 

3. Preview the page in your browser.  You may get the following warning: 
 

 
 

Just click OK to save your changes.  Once the browser presents you with your webpage, 
click on the link and observe the results.  You will notice that the anthracite.html file has 
opened in the left frame.  We want this file to open in the main frame.   

Redirecting Links to a Particular Frame 
 
1. Making sure that you have the Anthracite Coal link selected (click on it once), 

redirect the opening page to the correct frame by choosing RockInfoFrame  as 
the Target for this link. 
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2. Rather than having to specify a target for every link on a page, you can specify a 
default target by specifying it with the <base target = “frame”> tag.  For this 
example, add the line of html code  <base target =”RockInfoFrame”> to the 
header area of the rockindex.html page.   

 

 
 

3. Link the text Granite Gneiss Boulder to granite_gneiss.html, but don’t set the 
target property.  Preview it in the browser and confirm that the target is working 
properly. 

 
4. Link up the rest of the rocks to their pages: 
 

Keweenawan Conglomerate   →  keweenawan.html 
Neptheline Syenite   →  neptheline.html 
Porphyritic Biotite Granite  →  porphyritic.html 
Tyndall Stone    →  tyndall.html 

Title Attributes for Frames 
 
You may want to set the title attribute for a frame to improve accessibility (when visitors 
to your site choose to Bookmark or Add to Favourites from their browsers).   
 
1. From the Frames Panel select the RockListInfo frame. 
 
2. From the Modify pull-down menu, select Edit Tag.    
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3. Select Style Sheet/Accessibility category. 
 
4. Type in Geological Garden Rock List across from the Title option. 
 

 
 

5. Click on OK. 

Leaving a Framed Page 
 
If you have links that take the user outside of the framed page, such as to the University 
of  Waterloo’s home page, you need to specify a target of “_top” to indicate that the link 
page opens not in a frame, but in the entire browser window. 

A Link to Another Page 
 
1. We will add the University of Waterloo logo to the header frame. Your page 

should look similar to the example below. 
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2. Add a link to the image so that it points to the University of Waterloo’s Home 
Page (http://www.uwaterloo.ca). 

 
3. Set the target to be _top. 
 

 
 
Preview in the browser to confirm that the link works properly.    
 

Note:  A number of main size pages have code in them so that they “breakout” of a 
framed page.  The University of Waterloo’s home page is one of these.  If you wish, 
remove the target and try the page again.  Even though the University’s page would work 
without the target set, it is a very good idea and style to set the target when leaving your 
framed page. 
 
Here are some other options for setting the Target property: 
 

• _blank   opens the linked document in a new browser window, leaving the current 
window untouched. 

• _parent   opens the linked document in the parent frameset of the frame the link 
appears in, replacing the entire frameset 

• _self        opens the link in the current frame, replacing the content in that frame. 

Browsers That Don’t Support Frames 
 
Older browsers and text browsers may not support frames, so it is good practice to 
provide for such situations.  You may either tell visitors to your web page that they need 
a frame compatible browser to view the site or supply a non-framed page for them. 

No-Frames Content 
 
1. To specify what is to appear if the browser doesn’t support frames, you need to 

edit the no frames content of the frameset.  From the Modify pull-down menu, 
select Frameset and choose Edit NoFrames Content. 
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2. This opens a “new” document where you can put in the text and graphics that you 
want to appear, if the browser does not support frames.   

 

 
 
3. To return to the framed version of the page, just uncheck the Edit NoFrames 

Content option by accessing the Modify pull-down menu and selecting Frameset 
again. 

 
 
 
 


